HPE VM Explorer 6.3 now compatible with vSphere…

HPE VM Explorer 6.3 now compatible with vSphere 6.5 – via ESX Virtualization

HPE VM Explorer 6.3 now compatible with vSphere…

Several backup products still need updates to be compatible with latest VMware vSphere 6.5. This is not the case of HPE VM Explorer 6.3 (Previously Trilead). There is a new release available (v. 6.3.1) for download which adds vSphere 6.5 compatibilities and more. We’ll discuss it in this post.


VMware Social Media Advocacy

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: